#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\t\{(ABC-\d{4}-\d+)\s?\}"
Local $sString = " {ABC-2019-9810 ABC-2019-9813}" & @CRLF & _
" {ABC-2019-9810}" & @CRLF & _
" {ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")