using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\t\{(ABC-\d{4}-\d+)\s?\}";
string input = @" {ABC-2019-9810 ABC-2019-9813}
{ABC-2019-9810}
{ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}