re = /\t\{(ABC-\d{4}-\d+)\s?\}/m
str = ' {ABC-2019-9810 ABC-2019-9813}
{ABC-2019-9810}
{ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end