import re
regex = re.compile(r"\t\{(ABC-\d{4}-\d+)\s?\}", flags=re.MULTILINE)
test_str = (" {ABC-2019-9810 ABC-2019-9813}\n"
" {ABC-2019-9810}\n"
" {ABC-2019-9810 ABC-2019-9813 ABC-2019-9813}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")