package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+\.\S{2,4}\/\S*`)
var str = `17:00:29 <%Amand> test.com/pin/59537845-blabla-test/
17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/
17:00:41 <%Amand> un "domaine.ext/..."
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}