re = /\S+\.\S{2,4}\/\S*/m
str = '17:00:29 <%Amand> test.com/pin/59537845-blabla-test/
17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/
17:00:41 <%Amand> un "domaine.ext/..."
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end