$re = '/\S+\.\S{2,4}\/\S*/m';
$str = '17:00:29 <%Amand> test.com/pin/59537845-blabla-test/
17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/
17:00:41 <%Amand> un "domaine.ext/..."
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);