import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\.\\S{2,4}\\/\\S*";
final String string = "17:00:29 <%Amand> test.com/pin/59537845-blabla-test/\n"
+ "17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/\n"
+ "17:00:41 <%Amand> un \"domaine.ext/...\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}