use strict;
my $str = '17:00:29 <%Amand> test.com/pin/59537845-blabla-test/
17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/
17:00:41 <%Amand> un "domaine.ext/..."
';
my $regex = qr/\S+\.\S{2,4}\/\S*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}