// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+\.\S{2,4}\/\S*").unwrap();
let string = "17:00:29 <%Amand> test.com/pin/59537845-blabla-test/
17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/
17:00:41 <%Amand> un \"domaine.ext/...\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}