import re
regex = re.compile(r"\S+\.\S{2,4}\/\S*", flags=re.MULTILINE)
test_str = ("17:00:29 <%Amand> test.com/pin/59537845-blabla-test/\n"
"17:00:29 <%Amand> test.test.com/pin/59537845-blabla-test/\n"
"17:00:41 <%Amand> un \"domaine.ext/...\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")