using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Description>([^<]+)\n";
string substitution = @"";
string input = @" <Description>TestData</Description>\n
Data</Description>\n
<Description>Test\n
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}