// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<Description>([^<]+)\n").unwrap();
let string = " <Description>TestData</Description>\\n
Data</Description>\\n
<Description>Test\\n
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}