$re = '/<Description>([^<]+)\n/m';
$str = ' <Description>TestData</Description>\\n
Data</Description>\\n
<Description>Test\\n
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;