import re
regex = re.compile(r"<Description>([^<]+)\n", flags=re.MULTILINE)
test_str = (" <Description>TestData</Description>\\n\n"
" Data</Description>\\n\n"
" <Description>Test\\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)