use strict;
my $str = ' <Description>TestData</Description>\\n
Data</Description>\\n
<Description>Test\\n
';
my $regex = qr/<Description>([^<]+)\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";