use strict;
my $str = ' <xxx >
< xxx >
< xxx>
< xxx
xxx<
xxx ';
my $regex = qr/([\s\S]*?)([a-z]+)/mp;
my $subst = '$2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";