re = /([\s\S]*?)([a-z]+)/m
str = ' <xxx >
< xxx >
< xxx>
< xxx
xxx<
xxx '
subst = '$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result