import Foundation
let pattern = #"([\s\S]*?)([a-z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<xxx >
< xxx >
< xxx>
< xxx
xxx<
xxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)