using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b";
string input = @"123@gmail.com.net
12a.a.3@gmail.com.net
123@gmail.com.net
12a.a.3@gmoil.com.net
12a.a.3@gmoil";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}