import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z0-9a-z._%+-]+@gmail\\.com\\.net\\b";
final String string = "123@gmail.com.net\n"
+ "12a.a.3@gmail.com.net\n"
+ "123@gmail.com.net\n"
+ "12a.a.3@gmoil.com.net\n"
+ "12a.a.3@gmoil";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}