const regex = /\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z0-9a-z._%+-]+@gmail\\.com\\.net\\b', 'g')
const str = `123@gmail.com.net
12a.a.3@gmail.com.net
123@gmail.com.net
12a.a.3@gmoil.com.net
12a.a.3@gmoil`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}