re = /\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b/
str = '123@gmail.com.net
12a.a.3@gmail.com.net
123@gmail.com.net
12a.a.3@gmoil.com.net
12a.a.3@gmoil'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end