// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b").unwrap();
let string = "123@gmail.com.net
12a.a.3@gmail.com.net
123@gmail.com.net
12a.a.3@gmoil.com.net
12a.a.3@gmoil";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}