import re
regex = re.compile(r"\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b")
test_str = ("123@gmail.com.net\n"
"12a.a.3@gmail.com.net\n"
"123@gmail.com.net\n"
"12a.a.3@gmoil.com.net\n"
"12a.a.3@gmoil")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")