package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Z0-9a-z._%+-]+@gmail\.com\.net\b`)
var str = `123@gmail.com.net
12a.a.3@gmail.com.net
123@gmail.com.net
12a.a.3@gmoil.com.net
12a.a.3@gmoil`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}