#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m):{2,}(*SKIP)(*F)|:"
Local $sString = "/path/to/file/namespace/filename:line_number:error message Namespace\ClassName::method()." & @CRLF & _
"" & @CRLF & _
"/path/to/file/namespace/filename:line_number:error message Namespace\ClassName:::::method()."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)