import Foundation
let pattern = #":{2,}(*SKIP)(*F)|:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/path/to/file/namespace/filename:line_number:error message Namespace\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\ClassName:::::method().
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)