import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":{2,}(*SKIP)(*F)|:";
final String string = "/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().\n\n"
+ "/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}