re = /:{2,}(*SKIP)(*F)|:/m
str = '/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result