package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):{2,}(*SKIP)(*F)|:`)
var str = `/path/to/file/namespace/filename:line_number:error message Namespace\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\ClassName:::::method().`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}