import re
regex = re.compile(r":{2,}(*SKIP)(*F)|:", flags=re.MULTILINE)
test_str = ("/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().\n\n"
"/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)