// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):{2,}(*SKIP)(*F)|:").unwrap();
let string = "/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}