use strict;
my $str = '/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().';
my $regex = qr/:{2,}(*SKIP)(*F)|:/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";