$re = '/:{2,}(*SKIP)(*F)|:/m';
$str = '/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().
/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName:::::method().';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;