import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<input\\sclass=\"InputfieldFileSort\")";
final String string = "<input class=\"InputfieldFileSort\" type=\"text\" name=\"sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7\" value=\"0\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}