import re
regex = re.compile(r"(<input\sclass=\"InputfieldFileSort\")")
test_str = "<input class=\"InputfieldFileSort\" type=\"text\" name=\"sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7\" value=\"0\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")