const regex = /(<input\sclass="InputfieldFileSort")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<input\\sclass="InputfieldFileSort")', '')
const str = `<input class="InputfieldFileSort" type="text" name="sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7" value="0">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}