$re = '/(<input\sclass="InputfieldFileSort")/';
$str = '<input class="InputfieldFileSort" type="text" name="sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7" value="0">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);