use strict;
my $str = 'the driver of the 1st vehicle hit the iv iv at a stop';
my $regex = qr/(?<!\S)iv(?!\S)/mp;
my $subst = 'insuredvehicle';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";