import Foundation
let pattern = #"(?<!\S)iv(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"the driver of the 1st vehicle hit the iv iv at a stop"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"insuredvehicle"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)