import re
regex = re.compile(r"(?<!\S)iv(?!\S)", flags=re.MULTILINE)
test_str = "the driver of the 1st vehicle hit the iv iv at a stop"
subst = "insuredvehicle"
result = regex.sub(subst, test_str)
if result:
print(result)