#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^;]*)(Herr|Frau)\s*(.*)"
Local $sString = "Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen"
Local $sSubst = "$2 $1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)