import Foundation
let pattern = #"([^;]*)(Herr|Frau)\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)