import re
regex = re.compile(r"([^;]*)(Herr|Frau)\s*(.*)", flags=re.MULTILINE)
test_str = "Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen"
subst = "$2 $1$3"
result = regex.sub(subst, test_str)
if result:
print(result)