re = /([^;]*)(Herr|Frau)\s*(.*)/m
str = 'Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen'
subst = '$2 $1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result