using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^;]*)(Herr|Frau)\s*(.*)";
string substitution = @"$2 $1$3";
string input = @"Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}