const regex = /([^;]*)(Herr|Frau)\s*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^;]*)(Herr|Frau)\\s*(.*)', 'gm')
const str = `Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen`;
const subst = `$2 $1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);