package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^;]*)(Herr|Frau)\s*(.*)`)
var str = `Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen`
var substitution = "$2 $1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}