// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^;]*)(Herr|Frau)\s*(.*)").unwrap();
let string = "Mustermann Simon Herr Firma;nummer;beschreibung;Anzeigen";
let substitution = "$2 $1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}